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CHAPTER
ONE

INTRODUCTION

HDF Product Designer (HPD) helps data producers design conventional HDF5 products easily and generate consis-
tently interoperable data products by utilizing best practices and standards if they exist in their data user communities.
Conventions are defined using the powerful CLIPS expert system and designs can be re-used across product suites.

Key goals this application strives to fulfill:

* Facilitate creation of interoperable and standards-compliant data products in HDF5 as early as possible in the
project development process.

* Support multiple computing platforms without requiring the full software stack of development tools and li-
braries installed.

» Easy and intuitive editing (create, update, move, copy, delete) of HDF5 objects.

* Collaborative approach to product design (project/team/organization-wide).

* Incorporation of best practices and standards from targeted data user communities.

* Integration of compliance and interoperability tests into the design workflow.

* Content import from existing files.

» Export of designs as HDF5 files, HDF5/JSON, or as source code in several programming languages.

The Hierarchical Data Format (HDF5) provides a flexible container that supports groups and datasets, each of which
can have attributes. In many ways, HDFS5 is similar to a directory structure in a file and, like directory structures, the
same data can be structured and annotated in many ways. This flexibility empowers HDF5 users to arrange data in
ways that make sense to them. However, it can make it difficult to share data as users, and tools, must understand the
structure and the properties of data in order to use and understand it.

Many communities have successfully addressed this problem by creating conventional structures and annotations for
data in HDFS. This approach depends on data files (e.g., products) that carefully follow these conventions. In some
cases, designing and writing those files can be challenging or the user creating the product may be driven by local needs
that lead to deviations from the conventions. Unfortunately, even small deviations can cause problems for downstream
tools and future users.

What is a HDF5 product in the context of this software? HDFS5 product is the content that should exist in a single
HDFS file. This content is defined by the HDF5 objects (groups, attributes, datasets), their names, the hierarchies they
create (links and references), and attribute values. Dataset values are typically not stored in such files (unless they
qualify as metadata) thus this software cannot be used as a data server. Once completed, a HDF5 product is replicated
in many files (commonly on the order of tens of thousands or more) and filled with real data.

The HDF Product Designer code repository is hosted in the NASA Earthdata Code Collaborative.



http://clipsrules.sourceforge.net
http://hdfgroup.org
https://git.earthdata.nasa.gov/projects/HPD/repos/desktop/browse
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CHAPTER
TWO

WHAT’S NEW

The current version of HDF Product Designer is 1.4.0. It was released on 2016-06-01. Mentioned below are a few
notable highlights:

* Find & Replace is added.

* Open multiple projects and copy/move design between projects.

* JPL Metadata Checker service is added for ACDD and CF convention validation.
The Known Issues section lists known issues and limitations.

Release notes for previous versions are available below:

2.1 Version 1.3.0

Version 1.3.0 of the HDF Product Designer was released on 2016-01-01. Here are a few highlights:
* NetCDF CDL design importer fixed
* Design import from OPeNDAP DMR output
 Support for the variable-length string datatype
* Product documentation in the Microsoft Word docx format

* Notification about a newer version is displayed in login window on startup

2.2 Version 1.2.0

Version 1.2.0 of the HDF Product Designer was released on 2015-09-30. Here are a few highlights:
* Design import from netCDF CDL and HDF? files.
* Design export as Python, MATLAB, or IDL source code is greatly improved.
* Support for unlimited dataset dimension size.
* Improved handling of dimension scales in template files.

* For null-terminated string values, the string length in template files is now always one character longer to
accommodate the terminating null character.



https://www.unidata.ucar.edu/software/netcdf/docs/netcdf_utilities_guide.html#cdl_guide
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2.3 Version 1.1.0

Version 1.1.0 of the HDF Product Designer was released on 2015-07-01. Here are a few highlights:

o If a dataset has _FillValue attribute and CF or NUG convention is active, the value of _FillValue attribute will
be used as fillvalue of the dataset’s creation property when a design is imported.

* Compound dataset can be edited. Compound field can be dragged and dropped.
* Tree control uses white background and color icons.
* stderr/stdout messages are redicted to a separate window.

* IDL code generation is improved.

2.4 Version 1.0.0

Version 1.0.0 of the HDF Product Designer was released on 2015-04-01. This is the first official release of HDF
Product Designer Desktop.
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CHAPTER
THREE

KNOWN ISSUES

HDF Product Designer is still being actively developed. Below is a list of currently known issues or limitations:

Find and Replace start searching from the current tree node that user selected. Selecting Up option will not
search parent nodes unless search is already done using Find and user presses Find Next button.

Nested compound datatype is not supported.

Exporting designs with an array datatype compound field is not yet supported by all source code generators.
v1string (variable-length string) datatype cannot be used as a compound field.

Unsupported menu items are disabled. They are placeholders for future features.

Choosing both CF and NUG for conventions when creating a new design is not supported. Select either one
only.

Convention support works for new designs only. Changing design’s convention later is not supported.

Support for the HDF-EOS convention is still in very early stages of development. It will not yield valid HDF-
EOSS template files because it is not possible to assign values to datasets. Specifically, it is not possible to store
ODL string into the St ructMetadata dataset which is essential for HDF-EOSS library to access the file.

Export as works only for the current working version (label: HEAD).
Design/dataset/attribute/group names cannot be longer than 255 characters.

The / character is not allowed in object names and will be replaced with the _ character.
The size of attribute’s value cannot exceed one gigabyte.

The system utilizes user sessions that expire one day after the login time. The best practice is to log out (quit)
the application daily.

There is a 30-second timeout limit for all operations. Typically long executing operations, like template file
validation, may fail due to this timeout.

Generating HDFS5 template files for designs with large (> 64 kB) attributes may fail with an error: Unable to
create attribute (object header message is too large).

To report any new issue please visit the issue tracking website. (NASA Earthdata login required.)



https://bugs.earthdata.nasa.gov/browse/HPD/?selectedTab=com.atlassian.jira.jira-projects-plugin:summary-panel
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CHAPTER
FOUR

GETTING STARTED

Preparing to use HDF Product Designer is very simple. The following sections explain what and how.

4.1 Download

We provide the binaries for the following platforms:

Platform Binary SHA256 Checksum

Windows 7/8/10 Setup HPD_setup.ex¢ 255f7296f7fa3c2e780366d2dcbe23eal 966a828a9c88d2cf198ac6f4¢715¢e1f
Windows 7/8/10 HPD.exe 9d13c47642c1407d0e98596cf9c0d237e4bce91a4626¢3c1c468b5c2c5910f1e
Mac OS X (Mavericks or HPD.dmg 81410c79139222331f186a1f0d07c594af3f9c1d679c8bd3fdaad6a9a265¢ce3
newer)

Linux 2.6 (x86_64) HPD 035a61241bc19930340e2e1e22c4c9e5a73c1aabice0f62006db0e84ef50183b

Note: The Windows Setup binaries require administrator privileges to install. Use the other build for your Windows
platform if not having sufficient user privileges.

The Windows binaries require Microsoft Visual C++ 2008 Redistributable Package (x86).

4.2 Installation

The binaries in the Download section will work as is, no additional software tools or libraries are needed. Double
click on the icon to launch Product Designer.

For the Mac OS X binary, drag & drop the HPD.app from the HPD drive into the Application folder. Then double
click the application. Typically a security exception is required to open applications from unknown developers. Please
follow these instructions in that case.

When the application is installed correctly and starts successfully, it will display a login window requesting user
authentication information for the NASA Earthdata Login service.

If a new version is available the login window will also display a hyperlink next to the Login button with the text: New
version x.y.z of HPD is available! (Fig. 4.1). Clicking the hyperlink will open a browser window with the web page
from which the latest version of the HPD binaries can be downloaded.

If you want to build this application from the source, please visit its code repository.



https://wiki.earthdata.nasa.gov/download/attachments/49448010/HPD_setup.exe
https://wiki.earthdata.nasa.gov/download/attachments/49448010/HPD.exe
https://wiki.earthdata.nasa.gov/download/attachments/49448010/HPD.dmg
https://wiki.earthdata.nasa.gov/download/attachments/49448010/HPD
http://www.microsoft.com/en-us/download/details.aspx?id=29
http://www.imore.com/how-open-apps-unidentified-developer-os-x-mountain-lion
https://urs.earthdata.nasa.gov
https://git.earthdata.nasa.gov/projects/HPD/repos/desktop/browse
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=

Username

Password

Login Mew version 1.3.0 of HPD is available!

Fig. 4.1: New version notification hyperlink next to the Login button

4.3 User Authentication

HDF Product Designer does not collect or store any user information that can be used for authentication. It relies
instead on each user’s organization to provide such service for them.

Upon first-time successful authentication, user’s name (first and last) and email address are collected from the au-
thentication service and kept. User’s email represents their identity and that email is compared after each subsequent
authentication.

Note: Since HDF Product Designer obtains user personal information from their authentication service they have full
control of what information about them is shared between the application and the service.

Currently supported authentication services and how to configure them are explained below.

4.3.1 NASA Earthdata Login

If you don’t have NASA Earthdata Login account, please register first. The process requires NASA’s approval so it
may take some time.

Sign in to NASA Earthdata Login website, go to My Applications tab, press “Approve More Applications” (if neces-
sary), find and approve HDF Product Designer application to access your profile as shown in Fig. 4.2.

10 Chapter 4. Getting Started


https://urs.earthdata.nasa.gov
https://urs.earthdata.nasa.gov
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My Applications

< Approved Applications
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Earthdata Code Collaborative
Earthdata Wiki
Earthdata Feedback Module
Earthdata Website
ECHO Reverb

U N N

HDF Product Designer

APPROVEE MORE APPLICATIONS

Fig. 4.2: Web page for approving HDF Product Designer application
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CHAPTER
FIVE

USAGE

Major capabilities of the application are showcased and explained in this part of the guide. Please see the Getting
Started section on how to install this software if you would like to try out the features described here.

We use Microsoft Windows convention in describing key bindings. Please replace Ctrl key with Command key if
you are a Mac user.

5.1 Project

Projects are the main organizational and collaborative unit of this application. One project can have one or more users.
Every user must belong to at least one project. Collaboration among users is determined by project membership.

By default, every user belongs to two projects: Sandbox (shared among all users), and the personal project with
the user’s name. For any issue regarding projects and users, please contact the HPD Server administrator (ajele-
nak @hdfgroup.org). If requesting more users to join a project provide their emails as registered in the URS.

To open any of the user’s projects, use the menu Project > Open. You can open multiple projects if you want to copy
and move designs across projects.

To close a project, use the menu Project > Close.

Only HPD Server administrator can delete a project. Thus, Project > Delete menu will simply show a dialog box for
the HPD Server administrator’s email address.

5.2 Design

Designs represent content stored in HDFS files. A single project can have many designs and all users of the same
project can access its designs.

A design can have multiple versions and the version that can be edited is called current working version. The design
versioning system is a simple timeline of saved versions (checkpoints). At any point while working on a design, user
can opt to save its version as a checkpoint. Any of these checkpoints can be later promoted into the current working
version. Checkpoints must have unique labels, and the current working version’s label is HEAD and cannot be changed.

Currently supported design actions:
* Create a new design: Design > New.
* Open an existing design: Design > Open.
¢ Import design: Design > Import.
* Find an item in design(s): Design > Find.

* Replace an item in design(s): Design > Replace.
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* Checkpoint design’s current version: Design > Save.

* Close design in order to work on another one: Design > Close.

* Delete a design: Design > Delete. This action cannot be undone so please be cautious.
» Copy and paste design from one project to another: Ctrl+C and Ctrl+V.

* Move design from one project to another: Ctrl+X and Ctrl+V or drag & drop with mouse.

5.2.1 Import
Importing designs allows reuse of existing HDF5/HDF4/netCDF products as a starting point for creating new products.
Currently HPD Desktop supports import from the formats below:
» HDFS5 File
HDF5/JSON
HDF4 File Content Map
* NcML

« CDL
OPeNDAP DMR

All import formats except the HDF5 File are text-based so can be viewed or edited easily with any text editor before
import.

HDF5

To import a design from an HDFS5 file, please follow the steps below:
1. Select a project from the tree view (Fig. 5.4).
2. Choose Design > Import from > HDFS from the menu (Fig. 5.5).
3. A file selection dialog will appear. Select an HDF5 file and then Open. (Fig. 5.6).
4

. HPD Desktop will start loading the design from the file. It will update tree view dynamically during import
(Fig. 5.7) by scrolling down the view automatically as the tree grows. The importing process is completed when
the scrolling stops. Inspecting the import is recommended at this point.

5. If a parsing error occurs during the import, the design will be saved up to the point where the parsing error
occurred. The error message(s) will be shown in a separate wxPython stderr/stdout window.

Note: HDFS5 file content is converted to HDF5/JSON in memory prior to importing. Any HDFS5 feature not supported
by the hdf5-json tools will cause import operation to fail. HDFS5 file that has Unicode character cannot be imported.

HDF5/JSON

HDF5/JSON is a JSON representation of HDFS5 file content. JSON (JavaScript Object Notation) is a lightweight, open
format for data exchange, very popular in web applications. The h5tojson.py command line program can be used to
generate the JSON from any HDFS file.

To illustrate this functionality we have added to our HDF-EOS THREDDS server a capability to generate HDF5/JSON
for the sample NASA HDF-EOSS5/HDFS5 products hosted there, as shown in Fig. 5.1 and Fig. 5.2.

If you click one of sample NASA products, you’ll get HSJSON link under Access (Fig. 5.2).

14 Chapter 5. Usage


http://hdfgroup.org/HDF5
http://hdf5-json.readthedocs.org
http://hdfgroup.org/projects/h4map/h4map_writer.html
http://www.unidata.ucar.edu/software/thredds/current/netcdf-java/ncml/
https://www.unidata.ucar.edu/software/netcdf/docs/netcdf_utilities_guide.html#cdl_guide
https://github.com/HDFGroup/hdf5-json
http://hdf5-json.readthedocs.org
http://www.json.org
https://github.com/HDFGroup/hdf5-json/blob/master/util/h5tojson.py
https://eosdap.hdfgroup.org:8887/thredds/catalog/hdfdap/ftp/pub/outgoing/NASAHDF/catalog.html
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8 0o I/@ Catalog http://eosdap.hdf... 3 \\‘+

@'ﬂ https://eosdap.hdfgroup.org:8887 /thredds/c = | 'ﬁ‘b\ Search .\;' a9 R A =2 »

[E] Most Visited ~ 0 Getting Started Latest Headlines ~

KiCatalog http://eosdap.hdfgroup.org:8887/thredds/catalog/hdfdap

/ftp/pub/outgoing /NASAHDF/catalog

Dataset Size Last Modified

&) wasamor -
116.1

oco2_L25tdND_03945a_150330_B6000_150331024B816.h5 Mbytes 2015-04-01T14:07:402

imerem.hs Hf,;tzz 2013-12-23T19:25:002

1.201 01 02-04T06:00:002
acos_L2s 110101 02 Production v110110_L2s2800_r01 PolB_110124184213.hS Mbytes
653.8
TES-Aura L3-CH4 r0000010410_FO01_07.heS Kbytes 2010-11-02T20:50:372
1.198
TES-Aura_ L3-ATM-TEMP_r(0000010408 FO01_07.heS5 Mbytes 2010-11-02T20:50:372
172.2
TES-Aura L2-03-Nadir r0000011015 FO5_07.he5 Mbytes 2010-11-02T20:50: 362
401.5 5413 08-27715:42
55 00107 _STD F0359.h5 Hbyt.es -08-27T15: 442
204.4
SSMTI_37V_PM FT_ 2012 day366.h5 Kbytes 2015-04-27T18:35:412
3.422
SBUV2-NOAA17 L2-SBUV2N1712 2011m1231 v01-01-2012m0905£152911.h5 i SO el as kg
268.4 Can.
02012034.13m DAY EVSCI_V1.2DR_SSS_ldeg.hS Kbytes 2012-02-27T18:48:082
9.097
02011280003000.L2_EVSCI_V1.2.h5 Mbytes 2011-11-14T17:13:362

2.247

imerghh.h5 Mbytes 2013-12-23T19:25:002

E:] file-index/ -

Fig. 5.1: THREDDS web service for generating HDF5/JSON
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@ Catalog Services

@-’}l @ https://eosdap.hdfgroup.org:8887/thredds/c = @ | (Q Search ) wBE 9 sad2- » =

{] Most visited ~ @) Getting Started Latest Headlines ~

-
Initial TDS Installation

THREDDS Data Server

Catalog http://eosdap.hdfgroup.org:8887/thredds/catalog/hdfdap/ftp/pub
loutgoing/NASAHDF/catalog.html

Dataset: NASAHDF/TES-Aura_L3-CH4_r0000010410_F01_07.he5

* Data size: 653.8 Kbytes
» [D: hdfSDatasetScan/NASAHDF/TES-Aura_L3-CH4_r0000010410_F01_07.he5

Access:

OPENDAP: /thredds/dodsC/hdfdap/ftp/publoutgoing/NASAHDF/TES-Aura_L3-CH4_r0000010410_F01_07.he5
HTTPServer: /thredds/fileServer/hdfdap/ftp/publoutgoing/NASAHDF/TES-Aura_L3-CH4_r0000010410_F01_07.he5
NCML: /thredds/mcmifhdfdap/ftp/publoutgoing/NASAHDF/TES-Aura_L3-CH4_r0000010410_F01_07.he5

UDDC: /thredds/uddc/hdfdap/ftp/pub/outgoing/NASAHDF/TES-Aura_L3-CH4_r0000010410_F01_07.he5

ISO: /threddsfiso/hdfdap/ftp/publ/outgoing/NASAHDF/TES-Aura_L3-CH4_r0000010410_FO01_07.he5

H5JSON: /thredds/hSjson/hdfdap/ftp/pub/outgoing/MASAHDF/TES-Aura_L3-CH4_r0000010410_F01_07.heS
NCDismember: /thredds/ncdismember/hdfdap/ftp/publoutgoing/MASAHDF/TES-Aura_L3-CH4_r0000010410_F01_07.he5
CDL: /thredds/cdlihdfdap/ftp/pub/outgoing/NASAHDF/TES-Aura_L3-CH4_r0000010410_F01_07.he5

WCS: /thredds/wcs/hdfdap/ftp/pub/outgoing/NASAHDF/TES-Aura_L3-CH4_r0000010410_FO01_07.he5

WMS: /thredds/wms/hdfdap/ftp/publoutgoing/NASAHDF/TES-Aura_L3-CH4_r0000010410_FO01_07.he5

. NetcdfSubset: /thredds/ncss/grid/hdfdap/ftp/pubfoutgoing/NASAHDF/TES-Aura_L3-CH4_r0000010410_F01_07.he5

1.
2.
3.
4.
5.
6.
T.
8.
9.
0.
1

"

Dates:
* 2010-11-02T20:50:37Z (modified)
Viewers:

* Godiva2 (browser-based)
s NetCDF-Java ToolsU| (webstart)

Fig. 5.2: THREDDS catalog page displaying various access methods for one HDFS5 file
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Clicking the link will generate HDF5/JSON file without actual data (i.e., metadata information only) as shown in Fig.

5.3.

© 0 0 /[ hups:/jeosd..._FO1_07.he5 X \+

'@ﬁﬂhttps;.f'feosdap.hdfgroup.org:BBB?,f'thredlE:I c | Q, search " wBE 9 3 f A =

[ Most visited ~ @ Getting Started Latest Headlines ~

{
"apiVersion":
"datasets": {
"4£393406-307b-11e5-b51a-005056008d34": {
"alias": [
" /HDFEOS/CRIDS /NadirGrid/Data Fields/CH4"

"1.0.0",

'
"attributes": [

"name": "_FillValue",
"shape": {
"elass":
"dims": [
1

"H55_SIMPLE",

1
be
"type": {
"base": "H5T_IEEE_F32LE",
"class": "HST_FLOAT"
b
“"value": [
-999.0
1

"name": "MissingValue",
"shape": {
"class": "HS5S_SIMPLE",
"dims": [
1
1
b
"type": {
"base": "HS5T_IEEE_F32LE",
"elass": "HST_FLOAT"
b
"walue": [
-999.0
1

"name"”: "Title",
"shape": {
"class": "H5S_SCALAR"
b
“"type": {
"charSet":

“"HST CSET ASCII",

Fig. 5.3: HDF5/JSON output from THREDDS H5JSON access

If the HDF5/JSON representation of an existing HDFS file using the above method is saved to a file, it can be imported

by following the steps below.
1. Select project node from the tree view (Fig. 5.4).
2. Press Design > Import from > HDF5 JSON from menu (Fig. 5.5).
3. A file selection dialog will appear. Select an HDF5/JSON file (Fig. 5.6).

» |

4. Press the Open button. HPD Desktop will start loading the design from the file. It will update tree view
dynamically during importing (Fig. 5.7) and the tree view control will scroll down automatically as the tree
grows. If you don’t see any change in the tree view, it means it has completed importing. You may want to
scroll up to check your imported design.

5.2. Design
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Project

Design

|%| HDF Product Designer
Group Dimension Dataset Attribute Tools Help

Al = Sandbox

4 ¥ 1985017-1985024. m0483pfvs1-qual

hyoklee@hcfgroup. org cafelc7c-98f4-4a8d-8517-6cBbefarebed |
T ——

Fig. 5.4: HPD Desktop tree control view with a selected project
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e 00 |%| HDF Product Designer
Project Group Dimension Dataset Attribute Tools Help
%ﬁ New Ctri+N
Open Ctrl+O
Edit
Find
Replace
Delete
Save Ctrl+S
Lock
Close Ctri+W
Export as » HDF5 JSON
HDF4 Map
NehL
CDL
OPeNDAP DMR
MS Excel
Text (csv)
DB

Fig. 5.5: HPD Desktop menu selection for importing design from various sources
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_ipixi
Project  Design @roup  Dimension  Dataset  Attribute  Tools  Help
&= Sandbox
Choose an HDF5/350M file |
(Ii) | A - HyoKyung (Joe) Lee - - I Search Hyo-yung (Jog) Lee
Organize =  Mew folder 2o Eil @
7 Favorites = | .android HContacts | Tracing
B Desktop | .astropy jmDesktop |_|a.ison
& Downloads | ~continuum . Downloads |_|scalar. json
"5l Recent Places | .cordaova |+Favarites
i . .gissjava J.HPD
7l Libraries 1 .gradle |/ IdeaProjects
@ Documents )
] | .IdealC13 PLinks
J’ Music :
fi] Pictures L idlerc “[My Documents
Subversion 1 matplotib WMy Music
E Videos | .node-gyp =|My Pictures
| -plugman BMy Videos
1% Computer | .ssh |upip
&ose | L .unidata #5aved Games
AppData fiSearches
“- MNetwork ﬂ
File name: | =] |ison (json) |
Open |v| Cancel |
v
|h\roldee|ﬁl1dﬁ.;rotp.org | &
Fig. 5.6: HPD Desktop dialog box for opening an HDF5/JSON file
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800 |%| HDF Product Designer

Project Design Group Dimension Dataset Attribute Tools Help

= &= Sandbox
I ? 1885017-1985024. m0483pfv51-qual
:
- B
b E5data
v B images
P kg uints true_color]2000][512][3]/[2000][512][3](gz=6)
¥ B metadata
- ESFGDC
b [ES Distribution_|nformation
¥ 5 Identification_Information
&) string Access_Constraints = None
&) string User_Constraints = None
&) string Dataset_ldentifier = iss.2013339.1205.115906.L1B. hico.unknown.v01.15301. 100m.h5

b [ES Citation
hyoklee@hcfgroup. org cfbadsbs-77f0-4a80-973d-41023cEcfarf

Fig. 5.7: Updated tree view in HPD Desktop during HDF5/JSON file import
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5. If a parsing error occurs during the import, the design will be saved up to the point where the parsing error
occurred. You can examine an error message from the wxPython stderr/stdout message window.

Note: The HDF5/JSON importer in HPD Desktop has some limitations. For example, it cannot handle references and
custom datatypes. They will be ignored without any warning messages because they can make products inoperable

with netCDF.

Importing datasets without layout and filter creation properties will make them chunked with the size equal to their
size (the entire dataset is one chunk), and enable gzip (deflate) compression filter with level 6.

HDF4 XML

Importing designs from HDF4 files, for example existing NASA HDF-EOS2/HDF4 products, is possible using the
hdmapwriter tool which generates HDF4 file content map. HDF4 file content maps are XML documents that
describe file structure, metadata, and offsets and lengths of raw data. hdmapwriter is available from The HDF
Group project website.

To demonstrate the tool’s capability we exposed it as a THREDDS server’s data access service for sample NASA
HDF4 products, as shown in Fig. 5.8.

If you click one of sample NASA products, you’ll get H4MAP link under Access (Fig. 5.9).
Clicking the link will generate HDF4 map file in XML (Fig. 5.10).

Once the HDF4 XML representation of an existing HDF4 file using the above method is saved to a file, it can be
imported by following the steps below.

1. Select project node from the tree view (Fig. 5.4).
2. Press Design > Import from > HDF4 Map from menu (Fig. 5.5).
3. A file selection dialog will appear. Select an XML file (Fig. 5.6).

4. Press the Open button. HPD Desktop will start loading the design from the file. It will update tree view
dynamically during importing (:numref :tree-import-hdf5) and the tree view will scroll down automatically as
the tree grows. If you don’t see any change in the tree view, it means it has completed importing. You may want
to scroll up to check your imported design.

5. If a parsing error occurs during the import, the design will be saved up to the point where the parsing error
occurred. You can examine an error message from the wxPython stderr/stdout message window.

A useful feature of the HDF4 map writer is that it can merge a set of split file attributes (due to the attribute size
limitation in HDF4) into a single big string value in XML. To support such merged ODL string attributes, HPD
Desktop’s HDF4 map importer can parse the entire merged ODL string and re-represent it as a hierarchy consisting of
groups and attributes. Those re-constructed groups start with name Metadata_ in the imported design. For example,
Fig. 5.11 illustrates that the content of coremetadata is re-represented under the Metadata_core group.

The current HDF4 map importer has several limitations. It cannot import Table (a.k.a Vdata in HDF4) data. You will
see the following message in the console window:

INFO: Skipping unsupported Table Cloud Data

If importing Vdata is important, please try the NcML method.
Please note that HDF4 allows duplicate names under the same group but HDFS5 does not (Fig. 5.12).

In such case you’ll see an error message in the console window:

hpdws.create_group () :put:409

{"message": "Strip: Object with this name already exists.", ...}
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KiCatalog http://eosdap.hdfgroup.org:8887/thredds/catalog/ mnt/ftp

/pub/outgoing/NASAHDF/catalog.html

Dataset Size Last Modified

& HASAHDF

npp.2010361.hdf 37.32 Mbytes 2011-10-11T18:32:01Z

E:] file-index/ -

VIPO1P4.A2010001.002.hdf 106.8 Mbytes 2013-01-23T19:47:53Z
v2013335180706.L2_NPP_OC.hdf 93.48 Mbytes 2013-12-11T1B:15:1BZ
V20120012012366.L3m YR NPP_KD490 Kd_ 490 4km.hdf 149.3 Mbytes 2013-12-11T18:38:042
TOMS-EP_L3-TOMSEPL3 2000m0101_v8.HDF 229.2 Kbytes 2010-07-09T15:59:362
T2010001000000.L2_LAC_SST.hdf 22.12 Mbytes 2010-07-09T15:59:352
T20000322000060.L3m MO_NSST 4, hdf 111.9 Mbyktes 2010-07-09T15:59:31%
SW_S3E 2003100.20053531923.hdf 41.49 Mbytes 2010-07-09T15:59:112
£1999001.L3m DAY CHI_chlor a_9km.hdf 37.33 Mbytes 2011-11-08T16:39:142
§1997247162631.L2_ MLAC_OC.hdf 119.5 Mbytes 2010-07-09T15:59:032
0S_XWGRD3_2008001.20080021608. hdf 33.19 Mbytes 2010-07-09T15:58:422
019970011997031.L3m MO_A520_ 9.hdf 9.340 Mbytes 2010-07-09T15:58:362
01996306152450.1L2 GAC.hdf 24.74 Mbytes 2010-07-09T15:58:342
NPP_VSTIP L2.A2012002.2340.P1 03001.2012022162425.hdf 259.7 Mbytes 2012-10-12T20:19:102

NPP_DI16BRDF3_L3D.A2012241.h20v03.C1_03001.2012258151353.hdf 39.07 Mbytes 2012-10-12T20:19:01Z

Fig. 5.8: THREDDS web service for generating HDF4 file content map
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-
Initial TDS Installation

THREDDS Data Server

Catalog http://eosdap.hdfgroup.org:8887/thredds/catalog/mnt/ftp
Ipub/outgoing/NASAHDF/catalog.html

Dataset: NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF

« Data size: 229.2 Kbytes
« Data type: GRID
» ID: hdf4DatasetScan/NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF

Access:

OPENDAP: /thredds/dodsC/mnt/ftp/publoutgoing/NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF
HTTPServer: /thredds/fileServer/mnt/ftp/pub/outgoing/NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF
NCML: /thredds/ncmi/mnt/ftp/publoutgoing/NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF

UDDC: /thredds/uddc/mnt/ftp/publoutgoing/NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF

1S0: /threddsfiso/mnt/ftp/pub/outgoing/NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF

H4MAP: /thredds/h4map/mnt/ftp/publoutgoing/NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF
NCDismember: /thredds/ncdismember/mnt/ftp/pub/outgoing/NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF
CDL.: /thredds/cdlimnt/ftp/publoutgoing/NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF

WCS: /thredds/wes/mnt/ftp/publoutgoing/NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF

WMS: /thredds/wms/mnt/ftp/pub/outgoing/NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF

. NetedfSubset: /thredds/ncss/grid/mnt/ftp/pub/outgoing/NASAHDF/TOMS-EP_L3-TOMSEPL3_2000m0101_v8.HDF

SO O®ND O A WN

- =

Dates:
+ 2010-07-09T15:59:36Z (modified)
Viewers:

s Godiva2 (browser-based)
* NetCDF-Java ToolsUl (webstart)

Fig. 5.9: THREDDS catalog page displaying various access methods for HDF4 file
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This XML file does not appear to have any style information associated with it. The document tree is shown below.

- <h4:HDF4map version="1.0.1" xsi:schemaLocation="http://www.hdfgroup.org/HDF4/XML/schema/HDF4map/1.0.1
J/HDF4map.xsd">

—<lan

This XML file provides access to data stored in a companion HDF4 file without reguiring HDF4 softwar|

The HDF4FileInformation element provides information about the companion HDF4 file.

-

— <h4:HDF4FileInformation>
<h4:fileName>TOMS-EP_L3-TOMSEPL3_2000m0101_v8 HDF</h4:fileName:>

— <h4:fileLocation>
<hd:fileLocationType>filepath</h4:fileLocationType>
<h4:fileLocation Value>/mnt/ftp/pub/outgoing/NASAHDF</h4:fileLocation Value>
</h4:fileLocation>
<hd4:fileSize>229283</hd:fileSize>
<h4:md5Checksum>d2008f87cac152e65e3cc3e33b4ab988</hd:md5Checksum>
</h4:HDF4FileInformation>
+ €l

— <h4:HDF4FileContents>
— <h4:FileAttribute name="GranuleYear" origin="File Attribute: Arrays" id="ID_FA1">
<hd:datum dataType="int32" byteOrder="bigEndian"/>
— <h4:attributeData>
<h4:byteStream offset="228436" nBytes="4"/>

</h4:attributeData>
<h4:numericValues>2000</h4:numericValues>

</h4:FileAttribute>
— <h4:FileAttribute name="GranuleMonth" origin="File Attribute: Arrays" id="ID_FA2">

<hd:datum dataType="int32" byteOrder="bigEndian"/>
— <hd:attributeData>

<h4:byteStream offset="228501" nBytes="4"/>

Fig. 5.10: HDF4 XML output from THREDDS H4MAP access
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800 |%| HDF Product Designer
Project Design  Group Dimension Dataset Attribute Tools Help

b E5 descending_MW_only

b [ES location

~ B Metadata_core

¥ B INVENTORYMETADATA

Y string GRCUPTYPE = MASTERGROUP

+ [ MEASUREDPARAMETER

= [ MEASUREDPARAMETERCONTAINER

¢Y string CLASS = 17

v [BS QASTATS

¢ string CLASS = 17

hyoklee@hcfgroup. org 829ba7af-bst0-4ae2-a545-e5e5a22907f

Fig. 5.11: An imported HDF-EOS?2 file design with merged coremetadata
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HDFView 2.11

=

@

File Window Tools Help

@ | &

Recent Files

w | Clear Text

Log Info

Metadata

Fig. 5.12: HDFView displaying an HDF4 file that has two groups with the same name
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HPD Desktop doesn’t give any pop-up warning dialog messages for the above cases because they may happen quite
often. However, the HDF4 map importer will give a pop-up notification dialog message when it replaces / character
with __ for group/dataset/attribute names.

NcML

NcML is an XML representation of the metadata in a netCDF file (the information similar to the output of the ncdump
—h). The netCDF-Java library from Unidata can read most NASA HDF4 and HDFS5 files. Thus, the toolsUI, which is
based on netCDF-Java, can produce NcML easily from local HDF files. By clicking on the NcML tab, an HDF file
can be opened and then saved as NcML (Fig. 5.13).

NetCDF {4.5) Tools
Systern Modes Debug Help

[Viewer T Writer T NCDump | losp | CoordSys T FeatureTypes TTHREDDS Fmrc | GeoTiff | Units NcMLT URLdump ]

NemlEditor | Aggregation
dataset: /Users/hyoklee/Downloads/NPP_VSTIP_L2.A2012020.0000.P1_03001.2012022150246.hdf m @ @J % joinExisting v @J U g @J LJ

1, =vxml version="1.8" encoding="1TF-8"?=

7 enetedf wmlns="http: / www.unidata.ucar, edu/namespaces metedf meml-2,2" location="file: /Users/hyoklee/Downloads MPP_VSTIP_L2. A2012020, 6000, F‘\
<attribute name="HDFEOSVersien" value="HDFEDS 2.17" /=

<attribute name="ProcessingEnvirorment" walue="Linux minionS591 2.6.18-274.3.1.215 #1 SMP Tue Sep 6 28:13:52 EOT 2811 x85 64 x86_64 xB6_£
<attribute name="PreductionTime" value="2612-81-22 15:62:46.688" /=

=attribute name="PGE_StartTime" value="2812-A1-20 60:00:06.008" /=

<attribute name="PGE_EndTime" value="2812-81-28 B6:05:08.8680" /=

<gttribute name="NumSCEA RDR_TimeSegments" walue="[18]" /=

<attribute name="InputPointer" value="NPP_WMAE_L1.A2012826.0000.F1_83001. 2012021175928, hdf ,NFP_VIAE_L1. 42012020, 6608.P1_A3661. 2012621175¢
16 <attribute name="PGEVersion" value="P2.1.1" /=

11 <attribute name="Platform_Short_Name" walue="NPP' /=

12 <attribute name="PGE_Name" value="PGE388" /=

13 <attribute name="EastBoundingCoord" type="double" value="43.6256" /=

14 <attribute name="SouthBoundingCoord" type="double" walue="-75.3878" /=

15 <attribute name="LUTs_used" value="VIIRS-SURF-TEMP-COEFF-LUT_v1.5.65.86_LP,VIIRS-ICE-QUAL-LUT v1.5.85.88_LP" /=

16 <attribute name="EndingTime" value="AB8549.550A682" /=

17 <attribute name="Ending_Time_IET" value="[l.7857892e+15]" /=

18 <attribute name="LocalGranuleID" value="NPP_VSTIP_LZ.AZ812626.8666.P1_83661. 2012022156246, hdf" /=

19 <attribute name="Unagg_DayNightFlag" value="TS 6: Wight; TS 1: Both; TS 2: Day; TS 3: Day" /=

28 <attribute name="Beginning_Time_IET" value="[l.7857888=+15]" /=

21 <attribute name="LongName" walue="VIIRS/MNPP Surface Temperature Ice 5-Min L2 Swath IF 375m" /=

22 <attribute name="AlgorithmType" value="OPS" /= 17
23 <attribute name="StartTime" value="2012-81-26 86:66:03.258" /=
24 <attribute name="ProcessVersion" value="R1l_@38@1" /=

25 <gttribute name="SatelliteInstrument" walue="NPP_OPS" /=

26 <attribute name="ShortName" wvalue="NPP_VSTIP_LZ" /=

27 <attribute name="NorthBoundingCoord" type="double" value="-48&, 238" /=

28 <attribute name="ProxyDat=Type" value="VIIRS NGST PROXY 1.2 ORBITS; Metadata added by Land PEATE" /=
28 <attribute name="InztrumentShortname" walue="VIIRS" /=

38 <attribute name="BeginningTime" value="BABEABS. ZSEEBAZ" /=

31 <attribute name="westBoundingCoord" type="double" value="-39.2772" /=

32 <attribute name="LPEATE_AlgorithmVersion" walue="NPP_PRIceQual 1.5.85.88" /=
E8 <attribute name="EndTime" value="2812-81-28 68:65:49, 658" /=

34 <attribute name="NumSci_RDR_TimeSegments" value="[4]" /=

35 <attribute name="DayNightFlag" value="Both" /=

36 <attribute name="_History" value="Direct read of HDF4 file through COM library; HDF-EOS StructMetadata information was read" /= k
37 <attribute name="HDF4_Version" walue="4.2.4 [HDF Version 4.2 Release 4, January 25, 2009)" /= v
< S >

Fig. 5.13: ToolsUI displaying an HDF4 file content in NcML

The THREDDS data server, which is also based on NetCDF-Java, can generate NcML easily using a web browser.
We provide a demo THREDDS server for many NASA products from different NASA Earth data centers (Fig. 5.14)
for which NcML representation can be obtained. Please note that this generic THREDDS server is different from
the custom THREDDS server that provides HDF5/JSON and HDF4 Map access in the previous sections (e.g., port
number is different).

Clicking folders will lead you to a specific HDF product catalog that provides various access methods (Fig. 5.15).
Simply click the link next to NCML to get the NcML representation of NASA HDF products (Fig. 5.16).

Once obtained NcML representation of an existing HDF or netCDF file is saved to a file, importing it is done by
following the steps below:

1. Select project node from the tree view (Fig. 5.4).
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Fig. 5.14: THREDDS web service for generating NcML from HDF files
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FOF The HDF Group Test THREDDS Server (Static)

THREDDS Data Server

Catalog http://eosdap.hdfgroup.org:8889/thredds/catalog/NPPGRID
Icatalog.html

Dataset:
GRID/NPP_D16BRDF3_L3D.A2012241.h20v03.C1_03001.2012258151353.hdf

+ Data format: HDF
» Data size: 39.07 Mbytes
» [D: NPPGRID/NPP_D16BRDF3_L3D.A2012241.h20v03.C1_03001.2012258151353.hdf

Access:

OPENDAP: /thredds/dodsC/NPPGRID/NPP_D16BRDF3_L3D.A2012241.h20v03.C1_03001.2012258151353.hdf
HTTPServer: /thredds/fileServer/NPPGRID/NPP_D16BRDF3_L3D.A2012241.h20v03.C1_03001.2012258151353.hdf
NCML: /thredds/ncml/NPPGRID/NPP_D16BRDF3_L3D.A2012241.h20v03.C1_03001.2012258151353.hdf

UDDC: /thredds/uddc/NPPGRID/NPP_D16BRDF3_L3D.A2012241.h20v03.C1_03001.2012258151353.hdf

1S0: /thredds/iso/NPPGRID/NPP_D16BRDF3_L3D.A2012241.h20v03.C1_03001.2012258151353.hdf

WCS: /thredds/wcs/NPPGRID/NPP_D16BRDF3_L3D.A2012241.h20v03.C1_03001.2012258151353.hdf

WMS: /thredds/wms/NPPGRID/NPP_D16BRDF3_L3D.A2012241.h20v03.C1_03001.2012258151353.hdf
NetcdfSubset: /thredds/ncss/grid/NPPGRID/INPP_D16BRDF3_L3D.A2012241.h20v03.C1_03001.2012256151353.hdf

DND ;AW

Dates:
« 2012-10-12T20:19:01Z (modified)
Viewers:

* Godiva2 (browser-based)
* NetCDF-Java ToolsUl (webstart)

Fig. 5.15: THREDDS catalog page displaying various access methods including NcML
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This XML file does not appear to have any style information associated with it. The document tree is shown below.

— <netedf location="http://eosdap.hdfgroup.org:8889/thredds/dodsC/NFPGRID
/NPP_D16BRDF3_L3D.A2012241.h20v03.C1_03001.2012258151353 hdf">

<attribute name="HDFEQOSVersion" value="HDFEOS_V2.17"/>
<attribute name="ProcessingEnvironment" value="Linux minion5601 2.6.18-308.8.2.el5 #1 SMP Tue Jun 12 09:58:12
EDT 2012 xB6_64 x86_64 x86_64 GNU/Linux"/>
<attribute name="ProductionTime" value="2012-09-14 15:13:53.000"/>
<attribute name="PGE_StartTime" value="2012-08-28 00:00:00.000"/>
<attribute name="PGE_EndTime" value="2012-09-13 00:00:00.000"/>
<attribute name="GranuleEndingDate Time" value="2012-08-28 02:05:34.700,2012-08-28 05:16:11.600,2012-08-28
06:55:46.100,2012-08-28 08:31:04.550,2012-08-28 08:35:20.600,2012-08-28 08:41:02.000,2012-08-28
10:16:20.450,2012-08-28 10:20:36.500,2012-08-28 10:26:17.900,2012-08-28 11:55:54.950,2012-08-28
12:00:11.000,2012-08-28 13:45:26.900,2012-08-28 17:15:58.700,2012-08-28 20:40:49.100,2012-08-28 22:20:23.600"/>
<attribute name="LongName" value="VIIRS/NPP 16-Day Albedo L3 1km SIN Grid"/>
<attribute name="PGEVersion" value="C2.1.1"/>
<attribute name="Platform_Short_Name" value="NFP"/>
<attribute name="GranuleBeginningDateTime" value="2012-08-28 02:01:18.650,2012-08-28 (05:10:30.200,2012-08-28
06:50:04.700,2012-08-28 08:25:23.150,2012-08-28 08:31:04.550,2012-08-28 08:35:20.600,2012-08-28
10:10:39.050,2012-08-28 10:16:20.450,2012-08-28 10:20:36.500,2012-08-28 11:50:13.550,2012-08-28
11:55:54.950,2012-08-28 13:41:10.850,2012-08-28 17:10:17.300,2012-08-28 20:35:07.700,2012-08-28 22:16:07.550"/>
<attribute name="AlgorithmType" value="SCIENCE"/>
<attribute name="TileID" value="51020003"/>
<attribute name="ProcessVersion" value="C1_03001"/>
<attribute name="SatelliteInstrument” value="NPP_SCI"/>
<attribute name="PGE_Name" value="PGE364"/>
<attribute name="EastBoundingCoord" type="double" value="60.016667"/>
<attribute name="ShortName" value="NPP_D16BRDF3_L3D"/>
<attribute name="NorthBoundingCoord" type="double" value="60.0"/>
<attribute name="ProxyDataType" value="VIIRS NGST PROXY 1.2 ORBITS; Metadata added by Land PEATE"/>
<attribute name="RangeEndingTime" value=" 11:55:54.950"/>
<attribute name="InstrumentShortname" value="VIIRS"/>

Fig. 5.16: NcML output from the THREDDS NCML service
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Press Design > Import from > NcML from menu (Fig. 5.5).
A file selection dialog will appear. Select an NcML file (Fig. 5.6).

Press the Open button. HPD Desktop will start loading the design from the file and save the design on HPD
Server. It will update the tree view dynamically (Fig. 5.7) by scrolling down as the tree grows. If you don’t
see any change in the tree view, it means it has completed importing. You may want to scroll up to check your
imported design.

. If a parsing error occurs during the import, the design will be saved up to the point where the parsing error

occurred. The error message(s) will be displayed from the wxPython stderr/stdout message window.

NetCDF CDL

The network Common data form Description Language (CDL) is a text representation of a netCDF file that is used as
input and output by the netCDF utilities.

To import a CDL file, please follow the steps below:

1.

Select a project from the tree view (Fig. 5.4).

2. Choose Design > Import from > CDL from the menu (Fig. 5.5).
3.
4

From a file selection dialog pick a CDL file (Fig. 5.6).

. HPD Desktop will start loading the design from the file. It will update the tree view dynamically (Fig. 5.7) by

scrolling down as the tree grows. Importing is finished when the scrolling stops.

If a parsing error occurs during the import, the design will be saved up to the point where the parsing error
occurred. The error message(s) will be displayed in the wxPython stderr/stdout message window.

OPeNDAP DMR

The OPeNDAP Dataset Metada Response (DMR) is an XML representation of the metadata from a remote data source
hosted by an OPeNDAP server. DMR is based on the DAP 4.0 protocol. DMR is replacing the DAP 2.0-based DDX
and keeps evolving. DMR support may break at any time if its specification changes in between this application’s
releases.

To import an OPeNDAP DMR, please follow the steps below:

1.
2.
3.

Select a project from the tree view (Fig. 5.4).
Choose Design > Import from > OPeNDAP DMR from the menu (Fig. 5.5).
A text dialog box will appear. Enter an OPeNDAP server DMR URL (Fig. 5.2.1).

800 %] Input Text

Enter OPeNDAP DMR URL:

t.opendap. org/dap/data’hdfs/grid 1 _2d hs.dmr.xm I|

,%' Cancel {ﬂgﬁ
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4. HPD Desktop will start loading the design from the server. It will update the tree view dynamically (Fig. 5.7)
by scrolling down as the tree grows. Importing is finished when the scrolling stops.

5. If a network error or parsing error occurs during the import, the design will be saved up to the point where the
parsing error occurred. The error message(s) will be displayed in the wxPython stderr/stdout message window.

5.2.2 Export

A design can be exported in several formats: HDF5 template file, HDF5/JSON, and as Python, MATLAB, IDL, or
FORTRAN source code. The generated source code can produce the template file and, if modified to write actual data,
final HDFS products.

Note: Due to varying level of support for the HDF5 features in different programming languages not all source code
exports may be available for some designs.

HDF5 Template File

Template files represent a design as an HDFS5 file. They do not contain any real data but their structure, the names
of groups/datasets/attributes, and metadata (attribute values) accurately represent the design. Therefore these files are
ideal for quickly verifying the design by testing its template file with various display or visualization software, for
example HDFView.

To generate an HDFS template file from a design, please follow the steps below:
1. Select the design item in the tree first (Fig. 5.17).
2. Press Design > Export as > HDF5 from menu (Fig. 5.18).

3. You will be asked to provide a name for HDF?5 file. By default, it uses the same design name with extension
.h5.

4. Press the Save button. HPD Desktop will send a request to HPD server to a new HDF?5 file from design and
start downloading the file as soon as it is ready.

5. If exporting fails, the pop-up window will display the error message (Fig. 5.20).

6. A pop-up window will confirm successful export and show the full file path to the template file.

HDF5/JSON

HPD Desktop can export a design as HDF5/JSON.
1. Select a design item in the tree (Fig. 5.17).
2. Press Design > Export as > JSON from menu (Fig. 5.18).
3. If exporting fails, the pop-up window will display the error message (Fig. 5.20).
4. A pop-up window will confirm successful export and show the full file path to the exported file.

HDF5/JSON files can be edited with any text editor. This makes it possible to perform certain editing operations that
are currently not yet supported in the HPD Desktop, such as bulk search and replace. The modified file can then be
imported back or turned into an HDFS5 file with the jsontoh5.py.
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Fig. 5.17: HPD Desktop tree control view with a selected design
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Fig. 5.18: HPD Desktop menu selection for exporting design as HDF5 template file
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Fig. 5.19: HPD Desktop dialog box for saving design as HDF5 template file
36 Chapter 5. Usage



HDF Product Designer Documentation, Release 1.4.0

W HDF Product Designer o [m] 3

Project  Design  Group  Dimension  Dataset  Attribute  Tools  Help

&= Sandbox
B[] 12345new
=8 =)
E: hella
¢ Bl float32 k[10)[20]/[10][20] (gz=6)
: g wlen DIMENSION_LIST = [[u'datasets/869f41b0-c8bf-4e 1b-bf7c-0da3 1fsh49f5]]
£, compound k[30][30]/[30] [30](gz=8)

x

Exporting design as HDOF5 template failed:
[Errno €] Invalid object refence value: [j869f41b0-c8bf-4e 1b-bf7c-0da31fb45f5] not found

[ o |

hyoklee @hdfgroup.org |Fa0e 3ded-6045-4a0b-86dc 678 133ede0f 4

Fig. 5.20: HPD Desktop dialog message box for download failure
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Python Source Code

HPD Desktop can export a design as Python source code. The code requires the h5py package.
1. Select a design item in the tree (Fig. 5.17).
2. Press Design > Export as > Python from menu (Fig. 5.18).
3. If exporting fails, the pop-up window will display the error message (Fig. 5.20).
4. A pop-up window will confirm successful export and show the full file path to the exported file.

The Python code was tested with Python 2.7 and h5py versions 2.4 and 2.5.

IDL Source Code

HPD Server can generate IDL code using IDL’s HDFS5 routines.
1. Select a design item in the tree (Fig. 5.17).
2. Press Design > Export as > IDL from menu (Fig. 5.18).
3. If exporting fails, the pop-up window will display the error message (Fig. 5.20).

4. A pop-up window will confirm successful export and show the full file path to the exported file.

Note: IDL source code export will fail if:

* 8-bit signed integer (int 8) or variable string (v1string) datatypes are used.

MATLAB Source Code

HPD Server can generate MATLAB code using MATLAB’s HDFS5 routines.
1. Select a design item in the tree first (Fig. 5.17).
2. Press Design > Export as > MATLAB from menu (Fig. 5.18).
3. If exporting fails, the pop-up window will display the error message (Fig. 5.20).

4. A pop-up window will confirm successful export and show the full file path to the exported file.

Note: MATLAB source code export will fail if:

* Any dataset in a design has the total number of elements greater than 245 - 1.

FORTRAN Source Code

Warning: The functionality and support for HDF5 features of this source code generator currently lags signifi-
canly behind the others so it is not recommended for any serious use.

HPD Server can generate FORTRAN 90 code using HDF5 FORTRAN APIs.
1. Select a design item in the tree first (Fig. 5.17).
2. Press Design > Export as > FORTRAN from menu (Fig. 5.18).
3. If exporting fails, the pop-up window will display the error message (Fig. 5.20).
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4. A pop-up window will confirm successful export and show the full file path to the exported file.

To compile the exported FORTRAN code, the HDFS library is required and the HDF5 library must be compiled with
these flags: ——enable-fortranand ~—enable-fortran2003.

5.3 Group

You can add new group using menu items under Group. You can edit or delete an existing group using menu items.
You can also edit group directly by clicking and editing from the tree view. As soon as you change group, it will be
saved on HPD Server.

5.4 Dimension

A dimension is attached by dragging & dropping it onto a dataset. The DIMENSION_LIST and REFERENCE_LIST
attributes of the dataset and its dimension scale will be updated accordingly.

To detach a dimension, drag & drop dataset onto that dimension. Deleting a dimension will detach that dimension
from the dataset automatically.

5.5 Dataset

You can add new dataset using menu items under Dataset. You can edit or delete an existing dataset using menu items.
As soon as you change dataset, it will be saved on HPD Server.

The shape of dataset must be a set of integers separated by comma. For example, to create a dataset with 2x4 shape like
dset[2][4], please type 2,4 in the shape text box of New Dataset dialogue box. If you leave the shape empty, a scalar
dataset will be created. To specify unlimited dimension size, use . For example, to create a dataset with unlimited x
4 shape, please type *,4.

To create a compound dataset, create a dataset with compound type first. Then, select the dataset and create another
dataset under it. The child dataset becomes the field of compound dataset.

When you create a dataset, you can specify compression filters such as gzip, storage layout (chunk shape), and fill
value. By default, HPD users gzip compression with level 6 and chunked storage. If you leave chunk shape blank,
chunk shape will be same as dataset shape.

In tree view, storage layout is indicated with ¢/’ after dataset’s shape. If /> doesn’t appear, it means contiguous storage
is used. If an array style shape (e.g., [2][4]) is specified after °/’, it means chunking storage layout is used. Single ‘/°
means compact storage layout is used. The following table summarizes the storage layout notation in tree view.

Example Meaning

int8 d[10][20] Contiguous storage layout

int8 d[10][20]1/[2][4] | Chunking storage layout with shape 2x4
int8 d[10][20]/ Compact storage layout

Filters and the fill value are indicated within parenthesis and they are separated by commas. For example, int8
dset [10] (fv=-1,gz=6) means: gzip filter with compression level 6, with -1 as the fill value. The following
table explains the two letter notation of filters and fill value in dataset creation property.
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Notation | Meaning | Value Required?
fv fill value Yes

gz gzip Yes - [1,9]

sh shuffle No

fl fletcher32 | No

Since interoperability is most important, fill value in dataset creation property will be overwritten by _Fillvalue
attribute’s value if CF or NUG conventions are active and a_Fil1lValue attribute is defined for a dataset. The same
applies when importing designs from NcML and HDF4 map if either CF or NUG conventions are in effect.

5.6 Attribute

All operations on HDF5 attributes are available from the Attribute menu. Please note that creating, deleting, or
modifying any attribute is immediately recorded.

If you want to specify multiple values for a single attribute, you can surround the values in square braket and separte
them with comma (Fig. 5.21).

800 Edit Attribute
Type Name Value
| wlstring s vlattr ['does’, "it", "?']

| Cancel | | OK [

Fig. 5.21: How to add multiple values for a single attribute

5.7 Convention Support

* When you create a new design, you can pick a set of conventions that you want to use. However, you cannot
choose both CF and NUG at the same time.

* If you select convention, a toolbar will appear automatically.
» Using conventions will activate CLIPS expert engine except for HDF-EOS convention.
 To apply convention, you can select individual root group or dataset and press a button in toolbar.

» For HDF-EOS convention, you need to select the root group before you press any Point/ZA/Profile/Swath/Grid
button.

* Choosing custom convention allow you to load your own CLIPS code. You may want to download and edit a
sample CLIPS code that modifies the default values of ACDD convention and to test custom convention.
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5.7.1 CLIPS

Unless you’re comfortable with CLIPS programming, we don’t recommend you to modify existing CLIPS rules. If
you dare to customize CLIPS rules, please try them first on generic CLIPS engine, not PyCLIPS engine used in HPD
Desktop because a subtle mistake in CLIPS programming is hard to debug with HPD Desktop. HPD Desktop doesn’t
provide enough debugging message on system console. Although PyCLIPS generates my_trace.log, it may not be
useful for debugging either. The way PyCLIPS works in a packaged environment is a still mystery and we are still
investigating its limitation by trial-and-error.

The current user interface is only focused on adding attributes to groups and datasets suggested by CLIPS rules.
However, the current rule set is more sophisticated than what HPD Desktop GUI utilizes. For example, CLIPS rules
can handle dimensions but HPD Desktop doesn’t utilize them yet. We will address them in future versions.

Therefore, the only thing that HPD Desktop tested is to customize global name values using defglobal when
ACDD/NUG/CF conventions are used. We don’t know what will happen to HPD Desktop by writing a custom defrule,
so it’s entirely up to your hacking ability. If you have trouble with using PyCLIPS in HPD, please figure it out yourself
from source code or please support us by providing more funding if a serious effort needs to be made for custom
conventions.

5.8 Tools

HDF Product Designer provides tools for validating design and generating documentation.

5.8.1 Validation

HDF Product Designer provides several tools for testing design’s interoperability. Currently these tools rely on the
web services provided by the THREDDS and Hyrax data servers. We collectively refer to these interoperability tools
and services as HPD Online to distinguish them from those of the HPD Server.

HPD Online services can be invoked from the Tools menu at any time while working on a design (Fig. 5.22).

The selected design will be exported as an HDF5 template file and this file will be made available to the HPD Online
tools. An error message will be displayed if this process fails for any reason (Fig. 5.23).

Finally, the chosen HPD Online tool will run against the design’s HDFS file and report its result back via a web browser
window opened by the HPD Desktop.

This workflow can be repeated as many times as needed to either correct any reported error or maximize design’s
interoperability as defined by the tool.

For requesting addition of new tools to HPD Online please contact eoshelp @hdfgroup.org.

CDL

The network Common data form Description Language (CDL) is a text representation of a netCDF file that is used as
input and output by the netCDF utilities, which are based on the netCDF C library. These netCDF utilities are very
useful for interoperability testing so HPD Online supports obtaining a CDL output of a design.

The CDL output from HPD Online is directly generated by the ncdump tool. Correct display of the design’s content
assures it will be interoperable with any netCDF-C based tools.

* To validate a design with the ncdump -h command use the Tools > Validate > CDL menu.

e If no errors, the CDL output will be displayed in a web browser window (Fig. 5.24).
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Fig. 5.23: Error message for publishing HDFS5 file on HPD Online
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Fig. 5.24: CDL output from HPD Online
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Get as netCDF-3
netCDF-3 is a widely supported file format especially by the legacy tools. NASA data centers allow users to download
HDF files in the netCDF-3 format on demand.

HPD Online connects the Hyrax service which enables download of a design as a netCDF-3 file. This can benefit users
to ensure the files generated from the design will be interoperable with software which relies on the netCDF-3 format.

* To validate a design with netCDF-3 tools use the Tools > Validate > Get as netCDF-3 menu.

* If no errors, HPD Desktop will prompt for a file name and save the netCDF-3 content (Fig. 5.25).

RI=EY
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Organize *  Mew folder HE - @
J’ Music ;I | .android | unidata B My Videos
EI Pictures | .astropy AppData pip
gﬂ Subversion " Contacts Saved G
| .continuum Contac aved Games
¥ videos bl ?
| .cordova mDesktop fSearches
/8 Computer | .gissjava gDownloads ) Tracing
& o5 | .gradle [ :Favarites
¥ hyoklee (\jamiscr: ) IdealC13 JHFD
g# hyaoklee (\jjamthdf, | idlerc . IdeaProjects
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File name: I j
Save as type: InetCDF (*.nc) j
2/ Hide Foldersl Save Cancel |
v
|hyokl=e @hdfgroup.org |58863c25-e44c-4d 3e-a75-9a7418315b15 v
Fig. 5.25: HPD Desktop dialog box for saving design as netCDF-3 file
CF

The Climate and Forecast convention (CF) is one of the NASA ESDIS Standards Office (ESO) approved metadata
standards. The convention is quite important because there are many data access software that utilize it to geolocate,
plot, or subset data correctly. A subtle mistake in following the CF convention can make CF tools fail to load data.

HPD Online can check the CF convention compliance by using the ncdismember service powered by the CFChecker
via the THREDDS server. The ncdi smember tool will split the contents of a file along its HDFS groups into multiple
files. The CFChecker will then check each dismembered file and report on its CF compliance.
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It can also check the CF convention compliance by using the NASA JPL Metadata Compliance Checker. JPL’s checker
service uses CF version 1.6 while HPD’s ncdismember service uses CF version 1.5.

* To validate a design with CFChecker use the Tools > Validate > CF menu.
¢ If no errors, a CF compliance report will be displayed in a web browser window (Fig. 5.26).
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INFC: INIT: using area type table wersion: 2, date: 10 July 2013

INFCO: 2.4: no axiz information found in dimension wvariable=, not checking dimension order
WABNING: 3: variakle "scalar" containg neither long name nor standard name attribute
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INFC: INIT: checking compliance with convention CF-1.5
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hyolde

Fig. 5.26: CF compliance report from HPD Online. Note how the test .h5 file is split into the abc.nc and
root .nc files in the report.

ACDD

The Attribute Convention for Data Discovery ACDD is a set of global (root group) attributes that provide metadata
for improving the data’s discoverability. It works very well with other Earth Science conventions because there is no
overlap in the metadata content between them. Metadata cataloging tools use ACDD attributes to extract metadata
from files to support search or translation into other metadata formats such as DIF, FGDC, or ISO 19115. We highly
recommend using the ACDD attributes in your designs.

HPD Online utilizes THREDDS UDDC service. It provides an evaluation of how well the metadata contained in a
design conforms to the ACDD.

It can also check the ACDD convention compliance by using the NASA JPL Metadata Compliance Checker. JPL’s
checker service uses ACDD version 1.3.
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* To validate a design with the ACDD checker use Tools > Validate > ACDD menu.

e If no errors, a report will be displayed in a web browser window (Fig. 5.27).
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Title:
Total Score: 4/46

General File Characteristics

Number of Global Attributes 2
Number of Variables 0
Number of Variable Attributes 0
’m Number of Standard Names 0

R

Fig. 5.27: ACDD report from HPD Online

ISO

International Organization for Standardization (ISO) has published Geographic Information Metadata standard 19115.
NASA conventions and best practices for ISO 19115 are currently under development. HPD Online simply utilizes
THREDDS’s ISO service to provide ISO 19115 metadata description of a design.

* To obtain ISO metadata record of a design use Tools > Validate > ISO menu.

* If no errors, the design’s ISO metadata will appear in a web browser window (Fig. 5.28).

OPeNDAP

OPeNDAP stands for “Open-source Project for a Network Data Access Protocol”. OPeNDAP is both the name of a
non-profit organization and the commonly-used name of a protocol which the OPeNDAP organization has developed.
Hyrax is the official OPeNDAP server by OPeNDAP organization. Hyrax can serve both HDF4 and HDF5 data using
the HDF4 OPeNDAP handler and the HDF5 OPeNDAP handler.
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= sandbox
=-[) test (test description)
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é http:f /54.174.38.12 /threddsfiso/testAll/hpd f test.h5?catalog=http%3A%2F%2Fdata.hdfg = I [m] Ill
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CIS = [l hitp://54. 174.38. 12/t O 7] | 4| [# 54.174.38.12 X | | 5 9o £a3

| File Edit View Favorites Tools Help

<?xml version="1.0" enceding="UTF-8"7>
- <gmi:MI_Metadata xsi:schemalocation="http://www.isotc211.org/2005/gmi

http://www.ngdc.noaa.gov/metadata/published fxsd/schema.xsd"
xmins:xs="http://www.w3.org /2001 /XMLSchema"
xmins:xlink="http://www.w3.0org/1999 /xlink"
xmins:gm|="http://www.opengis.net/gml/3.2"
xmins:gts="http://www.isotc211.org/2005/gts"
xmins:gss="http://www.isotc211.org/2005/gss"
xmins:gsr="http:/ /www.isotc211.org/2005/gsr"
xmins:gmx="http://www.isotc211.org/2005/gmx"
xmins:srv="http:/ /www.isotc211.org/2005/srv"
xmins:gmi="http:/ /www.isotc211.0rg/2005/gmi"
xmins:gmd="http:/ /www.isotc211.org/2005/gmd"
xmins:gco="http:/ /www.isotc211.0rg/2005/gco"
xmins:xsi="http:/ /www.w3.0org/2001/XMLSchema-instance">

<gmd:fileldentifier gco:nilReason="missing"/>

- =gmd:language>
<gmd:LanguageCode codelistValue="eng"
codeList="http:/ fwww.ngdc.noaa.gov/metadata/published /xsd fschema/resources/i
</gmd:language=
- =gmd:characterSet>
<gmd:MD_CharacterSetCode codeListvValue="UTF8"
codeList="http:/ /www.ngdc.noaa.gov/metadata/published /xsd fschema/resourcesfi
hyakle </gmd:characterSet>

— [N R SR S T

Fig. 5.28: ISO metadata output from HPD Online
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The HDF5 OPeNDAP handler is a software that can be used to access HDF5 data via OPeNDAP’s Data Access Proto-
col. The HDF Group has designed and implemented this software. The handler can support OPeNDAP’s visualization
client tools that access NASA HDF-EOS5 (OMI, HIRDLS, MLS, TES and MOPITT) and some HDF5 (GPM, OBPG

and some MeASURES) products.

The HDFS5 handler provides two options: CF and generic. The CF option tries to make HDF5 products follow the CF
convention. The generic option serves HDF5 data as-is, which can break many CF tools. HPD Online uses HDF5
handler with CF option enabled to test the interoperability of a design.

* To validate a design with OPeNDAP server (Hyrax) use the Tools > Validate > OPeNDAP menu.
¢ If no errors, an OPeNDAP HTML form will be displayed in a web browser window (Fig. 5.29).

1ol

Project  Design  @roup  Dimension  Dataset  Attribute  Tools  Help

& Sandbox
=+ - test (test description)

=B

g int8 atr2 = 10

EIE, abc

“eff float32 scalar

,.é OPeNDAP Server Dataset Query Form - Internet Explorer - |EI|1|

CIS |@ htto://54.174.38.12/op O 7| | #2| [&] OPeNDAP Server Dataset Q... xl | I 5o el

J File Edit View Favorites Tools Help

OPeNDAP Server Dataset Access Form

Action: GetASCll | GetasNetCDF 3 | GetssNetCDF4 | Binary (DAP) Object | Show Help
Data URL: |http:,‘,|'54.1?4.38.12:SO,Fopendap.fdatafHPD,fhpd;’tesl.h5

Global Atiributes: |HDFS _GLOBAL.attriZ: 10

Variables:

Send questions or comments to.! supportid.opendap.ovg

~ HTML
~ 4.0

hyokle

Fig. 5.29: OPeNDAP server dataset access form from HPD Online. Note that the group hierarchy abc is flattened as
part of the variable name _abc_ by CF- enabled HDF5 handler because the CF convention do not have the notion of

group hierarchy.

THREDDS

The Unidata’s THREDDS Data Server (TDS) is a web server that provides metadata and data access for scientific files,
using OPeNDAP, OGC Web Mapping Service (WMS) and Web Coverage Service (WCS), HTTP, and other remote
data access protocols. The TDS is implemented as a Java servlet on top of the netCDF-Java library. Therefore, TDS
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is a good testbed for all netCDF-Java applications such as Panoply and IDV. If THREDDS can access and interpret a
design’s HDFS file correctly and other netCDF-Java tool can, too.

* To validate a design with THREDDS use the Tools > Validate > THREDDS menu.
¢ If no errors, a THREDDS dataset access page will be displayed in a web browser window (Fig. 5.30).

M HDF Product Designer =10 x|
Project  Design fGroup  Dimension  Dataset  Attribute  Tools  Help
ﬁ,i Sandbox
=+ | test (test description)
1=y
L intBattr2 = 10

El:| abc

i float32 scalar

/& Catalog Services - Internet Explorer =10l
o,

<> [l nitp: /54, 174.38. 12/ O x| | 42| [[] GPENDAP Server Dataset Q... | [] catalog Services xl | oA
| File Edit View Favorites Tools Help

I_T The HDF Group Test THREDDS Server A
The HDF Group
THREDDS Data Server

Catalog http://54.174.38.12/thredds/catalog/testAll/hpd/catalog.html
Dataset: hpd/test.h5

» Data size: 7.491 Kbytes
+ Data type: GRID
» ID: testDatasetScan/hpdftest h5

Access:

1. OPENDAP: /thredds/dodsCltestAllihpditest h5

2. HTTPServer: /thredds/fileServerftestAlllhpd/test.h5
3. NCML: /thredds/nemlitestAlllhpditest.hS

4. UDDC: /thredds/uddc/testAlllhpditest.h5

5. 180: jfthredds/izo/testAlllhpditest. hS
)
T
g

. WCS: jthredds/wes/testAlllhpditest.h5
. WMS: /thredds/wmsftestAll/hpd/ftest. h5
. NetcdfSubset: /thredds/ncss/ariditestAllhpditest.hs

i

Fig. 5.30: THREDDS dataset access from HPD Online

5.8.2 Documentation

Preparing product documentation is often a repetitive task, especially for designs where large number of HDFS5 groups,
datasets, and attributes have to be described. To reduce the mundane workload and speed up the process, design
documentation as Microsoft Word docx file can be stored locally as a starting point for further editing. The formatting

of such documents is deliberately minimal to allow easier adjustment to the final style. Documentation content consists
of:

* Design’s name and version as the document title.
* A sentence below the title with the timestamp of document’s creation.

* Group names as section titles.
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* Group’s attribute information (name, datatype, shape, value) in a table with single line borders.
» Dataset names as titles of subsections under their parent groups.
 Dataset information (parent group, datatype, shape, and max. shape) in a table with single line borders.

 Dataset’s attribute information (name, datatype, shape, value) in a table with single line borders.

HDF5 dimension scales are distinguished from ordinary HDF5 datasets by having Dimension Scale in their
subsection title.

Note: This is an experimental feature and the formatting and content of generated Microsoft Word files may change.
We solicit user comments and suggestions on how to improve the utility of the produced material.

To obtain design documentation:
* Select the Tools > Document > MS Word menu option.

* If no errors, a dialog window to choose a file name for the MS Word document will appear (Fig. 5.31).

%| HDF Product Designer
Project Design Group Dimension Dataset Attribute Tools Help
- el v |3|
800 |%| Generate product documentation in MS-Word...
Name: [6SSTF_NCEP 32008 12 3 1[I
Save in folder: 4 IE"hyaklu Create Folder
Places | Name v ‘ Size‘ Modified‘ —
7, Search [ Desktop 03/18/15
& Recently Used [~ bin 01/28/15
= hpd [ cf 03/20/14
= [ conventions 08/13/13
= Desktop [ data 05/31/13
[ File System [ include 01/15/14
= jsen 07/22/15
A= 1k D1/15(14
[ mvn 11/12/13
) sre 11/25/15
Erx 11/258/15
g MS Word (*.docx) | ¥ |
_ﬂ‘i %gancel ‘ Ega\re |

Fig. 5.31: Saving design’s product documentation as a Microsoft Word file
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5.9 Shortcut Keys

The following shortcut keys are supported.

Key Function
Ctrl+Shift+O Open Project
Ctrl+Shift+W Close Project
Ctrl+Q Quit

Ctrl+O Open Design
Ctrl+W Close Design
Ctrl+C Copy

Cul+X Cut

Ctrl+V Paste

DEL Delete
Ctrl+F Find
Ctrl+(Shift)+H (Mac) | Replace
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CHAPTER
SIX

APPENDIX

This part of the guide is not essential for using the application. It provides additional information about the overall
system design and specific software components.

6.1 System Design

HDF5 HDF4 Map netCDF
JSON XML NemL oL HDF>
Hyrax,
THREDDS
publish Server
Desktop RESTful
App Server ]
Data Store
v
HDF5 ( Flexible Output
JSON
;7 v v v v v v

HDFS File Product

Template |[Pocumentation Fortran IDL MATLAB Python

Fig. 6.1: HDF Product Designer system diagram

HDF Product Designer has three main components: Desktop Client, RESTful Server, and Data Store. The fourth
component, HDF5 Server, at present provides the online validation services, such as those afforded by the Hyrax and
THREDDS data servers. The best approach to integrating it with the other components is being investigated.

The main components are described in more detail below.
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6.1.1 Desktop Client

The client is the only part of the system directly accessible to users. It serves as the GUI front end to the capabilities
provided by the RESTful server. It is written in Python using the wxPython GUI toolkit. This makes it possible to
support the three major computing platforms (Windows, Mac OS X, and Linux) from the same source code while
maintaining the native GUI look and feel.

Besides providing GUI functionality to the standard HDFS5 content editing, the capabilities unique to the client are
design import and convention-based support during design development phase. For design import, the client reads in
file content description in several supported formats and translates it into the series of web requests to the RESTful
server which is responsible for storing that information.

Convention support during design development phase is achieved by running internally a CLIPS rule engine and
executing a set of rules applicable for specific convention and editing action, for example, creating an HDFS5 dataset
and the CF convention. PyCLIPS module is used as the interface between the client and the CLIPS engine.

6.1.2 RESTful Server

This server provides the back end support for all the capabilities of the HDF Product Designer. These capabilities are
exposed as RESTful application programming interface with the intention to allow more than one client application to
be developed. The client-server communication is secure because only requests that use the HTTPS communication
protocol are accepted.

Capabilities unique to the server are:
* User authentication
* Create, read, update, delete project/design actions
* Design export (template file, source code)
* Generate design template files for validation services

The latest server’s documentation is available here.

6.1.3 Data Store

The store is the data persistence layer of the HDF Product Designer. It keeps all the information about users, projects,
designs, HDF5 objects, and their relationships. The RESTful Server communicates exclusively with the store via the
SSL-encrypted connection thus all the exchanged information is secure.

The Data Store is using the PostgreSQL relational database. Because of the variety of possible HDFS content the
store utilizes JSON in the database extensively. This permits greater flexibility while not jeopardizing the proven
data consistency safeguards of relational databases. For example, all design modifications are executed as database
transactions.
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CHAPTER
SEVEN

INDICES AND TABLES

* genindex
¢ modindex

¢ search
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